Carrier operations in Florida and Caribbean islands impacted by Hurricane Irma
Resolved
Carriers are now conducting standard daily operations in the south central and southeastern regions of the U.S., and most areas of the U.S. Virgin Islands and Puerto Rico recently affected by Hurricanes Maria, Irma, and Harvey. Previous hazardous conditions across the areas have subsided, and carriers are now back to standard daily operations.
Note that some isolated areas in the U.S. Virgin Islands and Puerto Rico remain inaccessible because of local conditions.
Posted Oct 13, 2017 - 17:39 PDT
Update
Carriers are now providing normal pickup and delivery services in Florida and other states impacted by Irma. A few exceptions remain in Florida for areas that are without power or not safely accessible.
Posted Sep 19, 2017 - 17:17 PDT
Update
Carriers have suspended operations for the majority of areas in the Caribbean Islands, Florida, coastal Georgia and South Carolina. Depending on the severity of impact in the regions, carriers will continue operations with delays expected in the areas that are accessible.
Posted Sep 11, 2017 - 15:55 PDT
Monitoring
USPS has suspended operations in Puerto Rico, the Virgin Islands, and southern Florida due to Hurricane Irma. Other carriers, including FedEx, DHL, and UPS, are still monitoring potential impact, but may announce service interruptions soon.
Posted Sep 06, 2017 - 14:14 PDT
This incident affected: Carriers (Asendia, Canada Post, DHL eCommerce (Global Mail), DHL Express, FedEx, Hong Kong Post, Parcel Force, Royal Mail, UPS, USPS).