UPDATE Shenzhen Order Delays following Customs System Transition
Incident Report for Shipwire
Resolved
We are no longer experiencing any system delays due to the Custom System transfer.
Posted 3 months ago. Aug 07, 2018 - 20:13 PDT
Identified
We are currently experiencing order delays in our Shenzhen, CHN facility after the Customs System transfer by the General Administration of Customs in China. This is causing some orders to be held in the warehouse or held within the Free Trade Zone area. We will provide an update once the orders have been released.
Posted 3 months ago. Jul 26, 2018 - 12:54 PDT
This incident affected: Warehouses (Shenzhen, CHN).