Winter Storm Toby causing shipping delays from the Lancaster warehouse
Incident Report for Shipwire
Resolved
Our Lancaster facilities have resumed normal operations and all carriers are arriving for their usual pickups. Thank you for your patience.
Posted 2 months ago. Mar 22, 2018 - 14:08 PDT
Update
We have received notice that USPS was unable to pickup orders due to Winter Storm Toby. We apologize for any inconvenience this may cause and hope to resume normal operations in Lancaster by tomorrow.
Posted 2 months ago. Mar 21, 2018 - 15:51 PDT
Identified
Due to Winter Storm Toby, we have received notice from FedEx and UPS that they will not be picking up packages ready to ship today from our Lancaster facilities. If additional carriers are unable to pickup, we will update this post accordingly. We apologize for any inconvenience this may cause.
Posted 2 months ago. Mar 21, 2018 - 13:13 PDT
This incident affected: Carriers (FedEx, UPS) and Warehouses (Lancaster, PA).