Canada Post Strike Causing 1 Day Service Delays
Incident Report for Shipwire
Update
The Canada Post rotating strike is again targeting a number of locations including Mississauga, CAN and Vancouver, CAN. You may see pickup and delivery delays from our Mississauga and Richmond, CAN locations.

For more information visit:
https://www.canadapost.ca/web/en/comm/list.page?ecid=murl|ddn|lr|5
Posted 4 months ago. Nov 27, 2018 - 09:20 PST
Update
The Canada Post rotating strike continues to impact service.

Vancouver area was targeted last week and trailers have not been picked up since Friday. We may continue to see pickup and delivery delays from our Richmond location.

The strike continues to impact Toronto as well, and no trailer pickups are expected from our Mississauga location today.

For more information visit: https://www.canadapost.ca/cpo/mc/emailcampaigns/negotiations/negotiations_20181107A_en.html
Posted 4 months ago. Nov 13, 2018 - 10:24 PST
Update
The Canada Post rotating strike is again hitting the Greater Toronto Area. You may see pickup and delivery delays from our Mississauga location.

For more information visit: https://www.canadapost.ca/cpo/mc/emailcampaigns/negotiations/negotiations_20181107A_en.html
Posted 4 months ago. Nov 07, 2018 - 07:20 PST
Update
The Canada Post strike continues in the Greater Toronto Area for a second day. As this was not anticipated, Canada Post did not pick up trailers from our Mississauga, CAN warehouse. All of yesterday’s freight (October 23) now will incur a 2 day delay. For any questions or concerns, please email customercare@ingrammicrocommerce.com.
Posted 5 months ago. Oct 24, 2018 - 12:02 PDT
Monitoring
The Canada Post strike has targeted the Greater Toronto Area, impacting shipments in the Canada Post stream out for delivery as well as our trailer pick-ups today from CATO (Mississauga, CAN). Canada Post has confirmed that the trailers will depart from Mississauga, CAN after midnight today, Oct 23, however all orders shipping out of Mississauga with Canada Post will be impacted and experience a 1 day service impact. For any questions or concerns, please email customercare@ingrammicrocommerce.com.
Posted 5 months ago. Oct 23, 2018 - 14:40 PDT
This incident affects: Carriers (Canada Post) and Warehouses (Mississauga, CAN, Richmond, CAN).