FedEx Service Delays in Southern California
Incident Report for Shipwire
Resolved
All trailers have now been picked up and are being processed by FedEx.
Posted 17 days ago. Mar 01, 2019 - 10:46 PST
Monitoring
Due to heavy order volumes in Southern California, FedEx is experiencing service delays and a trailer backlog in the area. FedEx is actively working through the backlog of trailers that were not able to be processed overnight and delivery delays are expected.

We are continuing to monitor the situation and will provide updates as we receive them. Thank you for your patience.
Posted 18 days ago. Feb 28, 2019 - 10:59 PST
This incident affected: Warehouses (Redlands, CA, Mira Loma, CA, Hermosa, CA) and Carriers (FedEx).