Delays in carrier pickups from Pennsylvania due to winter storm
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted about 1 month ago. Feb 13, 2019 - 04:32 PST
Identified
Due to the winter storm in Pennsylvania, CA, carrier pickups from Lancaster and Jonestown may be delayed. For any questions or concerns, please contact customercare@ingrammicro.com.
Posted about 1 month ago. Feb 12, 2019 - 11:32 PST
This incident affected: Warehouses (Lancaster, PA, Jonestown, PA).