Winter Storm Grayson causing hazardous weather conditions
Resolved
This incident has been resolved.
Posted Jan 25, 2018 - 21:16 PST
Identified
Identified - Winter Storm Grayson is causing hazardous weather conditions across the Eastern Region of the U.S. All of our warehouses are still operating as usual, however, carriers are advising the following metropolitan areas will be experiencing service delays and disruptions today and for the next few days due to inclement weather.


Connecticut: Hartford, Wallingford
Delaware: Dover
Florida: Jacksonville, Tallahassee
Georgia: Albany, Savannah, Swainsboro, Valdosta, Waycross
Massachusetts: Boston, Brockton, Cape Cod, Southborough, Springfield, Stoneham
Maryland: Easton, Salisbury
Maine: Portland
North Carolina: Elizabeth City, Fayetteville, Kinston, Raleigh-Durham, Rocky Mount, Wilmington
New Jersey: Atlantic City, Bridgeton, Carteret, Moonachie, Pennsauken
New Hampshire: Manchester
New York: Albany, Amityville, Farmingdale. Holtsville, Riverhead
Pennsylvania: Bethlehem, Philadelphia, Pottstown
Rhode Island: Providence
South Carolina: Aiken, Beaufort, Charleston, Columbia, Florence
Virginia: Fredericksburg, Newport News, Norfolk, Portsmouth, Richmond
West Virginia: Bluefield
Washington D.C.
Posted Jan 04, 2018 - 17:49 PST
This incident affected: Warehouses (Rancho Cucamonga, Mira Loma, CA, Carrollton, TX, Millington, TN, Carol Stream, IL, New Lenox, IL, Lancaster, PA, Jonestown, PA) and Carriers (DHL eCommerce (Global Mail), FedEx, UPS, USPS).