Carrier pickup delays in Pennsylvania, USA due to winter storm
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted 25 days ago. Feb 21, 2019 - 05:07 PST
Identified
Due to the winter storm, there will be no carrier pickups from our Jonestown, PA and Lancaster, PA warehouses today. For any questions or concerns, please contact customercare@ingrammicroservices.com
Posted 26 days ago. Feb 20, 2019 - 12:12 PST
This incident affected: Warehouses (Lancaster, PA, Jonestown, PA).