The business reports are not being emailed out to merchants
Resolved
The billing issue is resolved, and all pending emails should be delivered to the customers.
Posted Apr 23, 2019 - 15:33 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 23, 2019 - 15:32 PDT
Identified
We have identified an issue where the business reports are not being sent out to our merchants. This is due to a billing issue with Mandrill which sends out the emails to the merchants.

ES is monitoring the issue, and I will update once the billing issue is fixed with Mandrill.
Posted Apr 23, 2019 - 12:08 PDT
This incident affected: Merchant portal (Merchant Application).