HTS/ECCN Holds Applied to Some Customer Accounts
Incident Report for Shipwire
Resolved
The issue has been resolved and orders impacted have had their holds recalculated.
Posted 8 days ago. Apr 17, 2019 - 10:20 PDT
Investigating
We are currently investigating an an issue causing HTS/ECCN holds to be applied to customer accounts. We apologize for any inconvenience this may cause and will provide an update once the issue is resolved. For any questions or concerns, please contact customercare@ingrammicroservices.com
Posted 9 days ago. Apr 16, 2019 - 13:34 PDT