Alaskan Storms Impacting Carrier Services
Resolved
This incident has been resolved.
Posted Jan 26, 2021 - 12:17 PST
Monitoring
Due to heavy storms and inclement weather in the Gulf of Alaska through Monday evening, you may experience delays in deliveries. We will continue to provide updates and advise accordingly as more information becomes available.
Posted Jan 18, 2021 - 13:34 PST
This incident affected: Carriers (FedEx, UPS, USPS).