Customers Making Credit Card Payments Issue
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 12:10 PDT
Monitoring
We have identified an issue for customers making payments via credit card payment method.

As we work to resolve this issue, we have determined a few workarounds in the meantime.
1. Switch your payment from a credit card to a U.S. Bank Account.
2. Switch your payment from a credit card to Paypal, which you can link to your credit card.
3. Reach out to our Customer Care team to have a wire transfer scheduled ($5,000 USD minimum requirement).

We anticipate this issue being resolved by the end of this week, and will update this message once credit card payments have begun working. For any additional questions, please email customercare@ingrammicroservices.com.
Posted Aug 06, 2019 - 10:24 PDT
This incident affected: Merchant portal (Merchant Application, www.shipwire.com).