FedEx Peak Surcharges Extension
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted Jan 04, 2021 - 09:35 PST
Monitoring
FedEx has continued to experience a surge in volume due to the impacts of COVID-19 and extremely high demand for capacity this holiday season. FedEx anticipates volume to continue to surge into the new year. Effective January 18th, 2021 until further notice, FedEx will continue to implement peak surcharges on SmartPost and Oversize shipments, as well as shipments that require additional handling.


The updated surcharges effective January 18th, 2021 are as follows:

Oversize Surcharge:

A $30.00 per package surcharge will be placed on US Express Package Services, US Ground Services, and International Ground Services (previously $52.50 per package).

Additional Handling Surcharge:

A $3.00 per package surcharge will be placed on US Express Package Services, US Ground Services, and International Ground Services (previously $4.90 per package).

Peak Surcharge:

A $0.75 per package surcharge will be placed on FedEx SmartPost Package Services (previously $1.00 per package).


Also, due to the disruptions in the global supply chain caused by COVID-19, a surcharge will be placed on all FedEx Express international parcel and freight shipments starting April 6th, 2021.

These surcharges will be applied until further notice. We will continue to keep you informed and updated through these unpredictable and challenging times.
Posted Dec 17, 2020 - 09:30 PST
This incident affected: Carriers (FedEx).