Carrier Pickup Delays in Mississauga, CAN Due to Inclement Weather
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted about 1 month ago. Mar 12, 2019 - 09:15 PDT
Identified
Due to heavy snowfall causing unsafe driving conditions in the Greater Toronto area today, 1-28 and tomorrow, 1-29, please expect delays in carrier pickups and deliveries. For any questions or concerns, please contact customercare@ingrammicroservices.com.
Posted 3 months ago. Jan 28, 2019 - 14:58 PST
This incident affected: Warehouses (Mississauga, CAN).