COVID-19 Updates
Resolved
This incident has been resolved.
Posted Jan 26, 2021 - 12:14 PST
Update
Please be reminded that our Customer Service phone line is fully re-opened and can be reached 24 hours a day, Monday-Friday. The Customer Care team can be reached at 1-888-744-7947 or customercare@ingrammicroservices.com.
Posted Aug 12, 2020 - 10:02 PDT
Update
We are committed to communicating all relevant updates regarding COVID-19 to our customers. Here are some updates we’d like to bring to your attention:

- Our Customer Care team continues to work through earlier delays. They are prioritizing requests and increasing their capacity each day. Thank you for your patience during this time.
- Projects and Value Added Services are facing delays in our Lancaster, Pennsylvania facility. The Operations teams are focusing on outbound fulfillment and we are proactively reaching out to customers that have current projects open.
- Italy and Spain are restricted in receiving B2B retail deliveries. Please contact us with questions or concerns about your B2B retail orders in the EU.

If you have any questions, please contact your Account Manager or our Customer Care Team at customercare@ingrammicroservices.com.
Posted Mar 18, 2020 - 15:36 PDT
Monitoring
Dear Valued Customer,

Our teams are working to ensure we are protecting the best interests of our customers, our associates, and our vendors globally. As of today, all of our sites are fully operational. If the situation changes, we will keep you informed if any of our sites experience a limited workforce or operational modifications.

Please refer to Ingram Micro’s statement from Scott Sherman, EVP of Human Resources, and Bill Ross, SVP of Global Operations and Engineering, addressing Ingram Micro’s response to the COVID-19 situation in further detail.
https://usa.ingrammicro.com/media/Documents/ingrammicro/c/corpcomm/Letter-regarding-Ingram-Micros-response-to-the-COVID-19-disease.pdf

Along with actively monitoring the situation, and as highlighted in our letter, we have a Business Continuity Management Program in place, which includes Business Continuity Plans (BCP) and Emergency Action Plans (EAP) that have been updated per ISO certification and are applicable to our individual offices and facilities. These Plans include response actions such as increased communication with all stakeholders and contingencies for the implementation of a deep clean sanitization of offices or facilities.

Ingram Micro and Shipwire, Inc. will continue to monitor the situation closely, including daily corporate and local monitoring of recommendations, risks and findings from the Centers for Disease Control and Prevention (CDC) and the World Health Organization (WHO).

Sincerely,
Marcelo Wesseler
Posted Mar 12, 2020 - 15:58 PDT
This incident affected: Warehouses (Rancho Cucamonga, Mira Loma, CA, Carrollton, TX, Millington, TN, Carol Stream, IL, New Lenox, IL, Lancaster, PA, Jonestown, PA, Tilburg, NLD, Laughton-Lewes, GBR, Shenzhen, CHN, Mississauga, CAN, Richmond, CAN, Eastern Creek, AUS, Hermosa, CA, Daventry, GBR, Waalwijk, NLD).