GLS Carrier Rate Increase out of Waalwijk, NL
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2024 - 22:04 PDT
Identified
Dear valued customer,

Please note that effective August 1, 2024, a carrier General Rate Increase (GRI) of 3% will apply to all parcels shipped via the GLS carrier service out of our WaalWijk facility in the Netherlands. If you have any questions concerning this GRI, please contact your account manager or the Customer Care Team at cscl-shipwire@cevalogistics.com for assistance.

Thank you for your continued partnership.
Posted Jul 03, 2024 - 22:04 PDT
This incident affects: Carriers (GLS (Netherlands)) and Warehouses (Waalwijk, NLD).