Possible delivery delays in California due to extreme fire hazards
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted Dec 05, 2019 - 14:56 PST
Investigating
California utility companies are cutting electrical power to parts of the state due to the threat of high winds and extreme fire hazards. Hundreds of thousands of homes and businesses are affected, including some Post Office locations. USPS Mail delivery continues where possible. Please check with your carrier for ongoing updates.
Posted Oct 28, 2019 - 11:55 PDT
This incident affected: Carriers (FedEx, UPS, USPS).