Delay in Orders Dropping to Laughton-Lewes, GBR
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted about 2 months ago. Jun 26, 2019 - 10:14 PDT
Identified
We are currently investigating an an issue impacting file submissions to our Laughton-Lewes, GBR warehouse. We apologize for any inconvenience this may cause and will provide an update once the service is restored. For any questions or concerns, please contact customercare@ingrammicroservices.com
Posted 5 months ago. Apr 02, 2019 - 16:09 PDT
This incident affected: Warehouses (Laughton-Lewes, GBR).