Yodel Xpress Services Unavailable to Northern Ireland
Resolved
This incident has been resolved.
Posted Feb 01, 2022 - 08:25 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 22, 2021 - 08:45 PST
Monitoring
Please be informed that Daventry, GBR carrier services Yodel Xpress 24 and Yodel Xpress 48 will be unavailable to Northern Ireland until further notice. Royal Mail, Parcelforce, Hermes, and DPD carrier services can be used for shipments to Northern Ireland.

If you have any questions, please contact customercare@ingrammicroservices.com.
Posted Jul 28, 2021 - 08:57 PDT
This incident affected: Warehouses (Daventry, GBR) and Carriers (Yodel).