DPD Classic Temporarily Unavailable from the Daventry, GBR Facility
Resolved
This incident has been resolved.
Posted Jul 06, 2021 - 08:07 PDT
Monitoring
Please be aware that DPD Classic is temporarily unavailable from the Daventry, GBR facility until further notice. This carrier service is experiencing technical difficulties that need to be resolved before service can be resumed. We are closely monitoring this situation and will continue to provide updates as they become available.
Posted May 19, 2021 - 12:21 PDT
This incident affected: Carriers (DPD) and Warehouses (Daventry, GBR).