Daventry, UK power outage
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 05, 2019 - 09:39 PDT
Monitoring
There has been a power outage at our Daventry, UK facility at approximately 4:50pm local time. This prevented our 5pm order run from being completed. Anything received after 4:30pm was not shipped today and may experience delays. We apologize for any inconvenience this may cause. For any questions or concerns, please contact customercare@ingrammicroservices.com.
Posted 2 months ago. Aug 09, 2019 - 15:07 PDT
This incident affected: Carriers (Asendia) and Warehouses (Daventry, GBR).