Carrier Responses and Updates to COVID-19
Resolved
This incident has been resolved.
Posted Jan 26, 2021 - 12:13 PST
Update
We are committed to keeping our customers informed of COVID-19 updates as we are informed by our partners and carrier network.

To stay up-to-date on carriers updates/responses to COVID-19, please refer to the carrier links below:
Europe
DPD (UK) - https://www.dpd.co.uk/content/products_services/covid-19-bulletins.jsp
Royal Mail (UK) - https://personal.help.royalmail.com/app/answers/detail/a_id/5317/~/international-incident-bulletin
Parcelforce (UK) - https://www.parcelforce.com/coronavirus
Yodel (UK) - https://www.yodel.co.uk/news/2020/march/covid-19/
GLS (NL) - https://gls-group.eu/EU/en/information-about-corona-virus
DHL (NL) - https://www.dhlparcel.nl/nl/zakelijk/corona-europa

US
FedEx - https://www.fedex.com/en-us/coronavirus.html
UPS - https://www.ups.com/us/en/service-alerts.page
USPS - https://about.usps.com/newsroom/service-alerts/
DHL eCommerce - https://www.dhl.de/coronavirus-en
DHL Express - https://www.simplydhl.com/covid-19updates

Canada
Canada Post - https://www.canadapost.ca/cpc/en/our-company/news-and-media/service-alerts.page
Purolator - https://www.purolator.com/en/articles/delivering-your-promises-safely-during-times-uncertainty

Australia
Australia Post - https://auspost.com.au/about-us/news-media/important-updates/coronavirus
Toll - https://www.tollgroup.com/news-and-media/news/toll-groups-response-covid-19

Shenzhen, CHN
Hong Kong Post - https://www.hongkongpost.hk/en/about_us/whats_new/press_release/index.html
FedEx Hong Kong - https://www.fedex.com/en-hk/coronavirus.html
DPEX - https://dpex.com/covid-19-service-suspension/
Posted Aug 27, 2020 - 15:43 PDT
Update
Due to an upsurge in Covid-19 cases in certain parts of Australia, carriers are noting delivery delays. Carrier delays are the result of reduction in air freight capacity and passenger flights, a significant increase in parcels volumes, hygiene and social distancing requirements in their networks. Further, Victoria has imposed stage 4 restrictions on Melbourne, but Australia Post and Toll will continue to operate in line with government regulations as essential service providers in Melbourne. For the latest information, please visit each carrier’s Covid-19 webpages:

Australia Post
https://auspost.com.au/about-us/news-media/important-updates/coronavirus/coronavirus-domestic-updates#delays

Toll
https://www.tollgroup.com/toll-service-updates
Posted Aug 04, 2020 - 16:08 PDT
Update
USPS is committed to identifying solutions to assist businesses impacted by the Coronavirus Disease 2019 (COVID-19) pandemic.

USPS is temporarily modifying how it handles mail that must be returned to the delivery office due to a full box, or the business not being open to receive delivery for an extended period.

Current postal policy is to return the mail to the delivery office, indicate the date the mail is first returned to be held, and hold for 10 days. In order to accommodate businesses during this challenging time, USPS will now extend the hold period to 30 days before returning the items to the sender.

Once the business reopens, delivery should immediately resume unless other arrangements have been made. If the business fails to make alternative delivery arrangements or does not submit a request to hold or forward its mail after 30 days, the process of returning mail to the sender will resume.

USPS management may make efforts to contact business owners for whom USPS is holding mail to discuss the alternative options.

If businesses make contact after the 30-day hold period and Moved, Left No Address (MLNA) orders have been processed, USPS will extend assistance as necessary to cancel and immediately resume delivery.

These instructions shall remain in place until further notice
Posted Apr 01, 2020 - 15:36 PDT
Update
We are committed to keeping our customers informed of COVID-19 updates as we are informed by our partners and carrier network.

The United States Postal Service (USPS) continues to use its existing processes for many of its operations and has provided answers for common questions/concerns they are receiving. For more information, see the USPS Coronavirus Statement at http://about.usps.com/newsroom

How is USPS handling mail for closed businesses?
Mail on the delivery route is returned to the Delivery unit and will be held for 10 days under current policies. Customers can request a temporary hold for their mail up to 30 days. Caller Box customers should contact their local office to discuss how they will be handling the pickup of this volume. Any high volume customer will be contacted to discuss pickup options as well.

How is USPS delivering mail under shelter in place declarations?
The Postal Service is classified as an essential government service operation, which allows us to continue operations.

How safe is the mail and mail transport equipment?
Current Centers for Disease Control and Prevention (CDC) and World Health Organization (WHO) guidance continues to indicate there is no evidence the virus is spreading through the mail. According to WHO, the likelihood of an infected person contaminating commercial goods is low, and the risk of catching the virus from a package that has been moved, traveled, and exposed to different conditions and temperatures is also low. This guidance remains true for mail transport equipment.

Is the USPS experiencing capacity issues due to reduced airline routes?
There are no domestic air capacity issues at this time. The Postal Service continues to work with International air carriers and contract air carriers to keep mail moving.
Posted Mar 20, 2020 - 13:51 PDT
Monitoring
We are committed to keeping our customers informed of COVID-19 updates as we are informed by our partners and carrier network.

To stay up-to-date on carriers updates/responses to COVID-19, please refer to the carrier links below:
Europe
DPD (UK) - https://www.dpd.co.uk/content/products_services/covid-19-bulletins.jsp
Royal Mail (UK) - https://personal.help.royalmail.com/app/answers/detail/a_id/5317/~/international-incident-bulletin
Parcelforce (UK) - https://www.parcelforce.com/coronavirus
Yodel (UK) - https://www.yodel.co.uk/news/2020/march/covid-19/
GLS (NL) - https://gls-group.eu/EU/en/information-about-corona-virus
DHL (NL) - https://www.dhlparcel.nl/nl/zakelijk/corona-europa

US
FedEx - https://www.fedex.com/en-us/coronavirus.html
UPS - https://www.ups.com/us/en/service-alerts.page
USPS - https://about.usps.com/newsroom/service-alerts/
DHL eCommerce - https://www.dhl.de/coronavirus-en
DHL Express - https://www.simplydhl.com/covid-19updates

Canada
Canada Post - https://www.canadapost.ca/cpc/en/our-company/news-and-media/service-alerts.page
Purolator - https://www.purolator.com/en/articles/delivering-your-promises-safely-during-times-uncertainty

Australia
Australia Post - https://auspost.com.au/about-us/news-media/important-updates/coronavirus
Toll - https://www.tollgroup.com/news-and-media/news/toll-groups-response-covid-19

Shenzhen, CHN
Hong Kong Post - https://www.hongkongpost.hk/en/about_us/whats_new/press_release/index.html
FedEx Hong Kong - https://www.fedex.com/en-hk/coronavirus.html
DPEX - https://dpex.com/covid-19-service-suspension/
Posted Mar 19, 2020 - 08:37 PDT
This incident affected: Carriers (Asendia, Australia Post, Canada Post, DHL eCommerce (Global Mail), DHL Express, DPD, FedEx, GLS (Netherlands), Hermes, Hong Kong Post, Netherlands Post, Purolator, Parcel Force, Royal Mail, StarTrack, Toll, UPS, USPS).