Purolator Extends Peak Surcharges
Resolved
This incident has been resolved.
Posted Jan 26, 2021 - 12:23 PST
Monitoring
Purolator is experiencing a continuation of Peak Season volumes, with unprecedented demand for their transportation services. Due to a continued surge in residential deliveries and special handling services, Peak Surcharges will remain in place. Effective January 17, 2021, and until further notice, one or more of the Peak Surcharges will be applied in addition to any existing shipping rates and surcharges to the applicable shipment. Below are the Peak Surcharges that will be in place:

Additional Handling - $3 per piece (previously $5 per piece)
Peak Oversized - $3 per piece (previously $5 per piece)
Peak Residential Heavyweight - $3 per piece (previously $5 per piece)
Peak Large Package - $32 per piece (previously $50 per piece)
Peak Over Maximum Limit - $90 per piece (previously $450 per piece)
Peak Residential Area - $0.40 per shipment (previously $1.50 per shipment)

Peak Season periods and Peak Surcharges are subject to change at any time. We will continue to keep you readily informed and updated.
Posted Jan 15, 2021 - 15:05 PST
This incident affected: Carriers (Purolator) and Warehouses (Mississauga, CAN, Richmond, CAN).