DHL Europlus Disabled to Non-EU Countries
Resolved
This incident has been resolved.
Posted May 18, 2021 - 11:20 PDT
Monitoring
DHL Europlus has been disabled on the Shipwire Platform to ship to non-EU countries. DHL Europlus will be suspended to the following destinations: Norway, Monaco, Great Britain, Guernsey, Jersey, Liechtenstein, Switzerland, and Andorra.

These changes will go into effect immediately and will be reflected in Shipwire until further notice.
Posted Apr 26, 2021 - 09:25 PDT
This incident affected: Warehouses (Tilburg, NLD, Laughton-Lewes, GBR, Daventry, GBR, Waalwijk, NLD).