COVID-19 Update in Australia
Resolved
This incident has been resolved.
Posted Oct 14, 2021 - 13:43 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2021 - 15:57 PDT
Investigating
Due to the current COVID 19 situation in NSW, our Eastern Creek facility will be going into Business Continuity Plan mode starting next week.

There will be some impact on the processing of orders, so please expect potential delays in the outbound shipping. Secondly, our carriers are also facing challenges with lockdowns in various states in Australia. Delays are expected at plus 1 – 2 days extra in the transit times.

If you have any questions, please contact customercare@ingrammicroservices.com.
Posted Aug 26, 2021 - 10:41 PDT
This incident affected: Carriers (Australia Post, StarTrack, Toll) and Warehouses (Eastern Creek, AUS).