Warehouse Operations Delay - Eastern Creek NSW, Australia
Resolved
This incident has been resolved.
Posted Feb 14, 2022 - 16:04 PST
Monitoring
Due to the spike in Covid 19 cases in Greater Sydney area, our Eastern Creek AUS facility is operating with limited manpower both inbound and outbound starting today.
To maintain a safe working environment, effective immediately we will be adjusting the operation service level as outlined below:

• Until further notice, all commercial orders will be tendered to the carrier the next business day after the order has been received and released from all holds.
• Consistent with normal business practice, retail orders will be processed with the priorities provided if any.

Currently, no specific call outs from carrier on the last mile deliveries or operations at their depots. all transportations are to be business as usual. Will update if any changes.

We are monitoring this situation closely and will continue to provide updates as more information becomes available.
Posted Jan 06, 2022 - 08:46 PST
This incident affected: Warehouses (Eastern Creek, AUS).