Intermittent connection issues on customer care phonelines
Incident Report for Shipwire
Resolved
This connectivity issue has now been resolved. Thank you for your patience.
Posted 7 months ago. Jan 16, 2019 - 15:12 PST
Identified
Our customer care phonelines are currently experiencing intermittent connection issues. Customers may experience difficulty or disconnection when attempting to contact via phone. We apologize for any inconvenience this may cause and will continue to monitor this issue and provide updates when resolved. For any questions or concerns, please contact customercare@ingrammicroservices.com
Posted 7 months ago. Jan 16, 2019 - 09:09 PST