Temporary Revision in Transit Times for FedEx Ground and FedEx Home Delivery Shipments
Resolved
This incident has been resolved.
Posted Jan 04, 2021 - 09:36 PST
Monitoring
Effective between 11/20/20 and 01/03/21, FedEx has temporarily increased transit times by one day for FedEx Ground & Home Delivery shipments to select destination zip codes for shipments from our U.S. fulfillment centers. This information is subject to change and we will keep you informed as we learn more from FedEx.

For a full list of impacted zip codes, please contact your account manager or customer care team at customercare@ingrammicroservices.com.
Posted Nov 20, 2020 - 15:37 PST
This incident affected: Carriers (FedEx).