Order delays at our Redlands, CA facility
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 08, 2019 - 11:00 PDT
Identified
Some orders out of our Redlands, CA facility are delayed due to a current issue with network latency. Our engineering team is actively working to resolve the issue. We sincerely apologize and thank you for your patience. For any questions or concerns, please contact customercare@ingrammicroservices.com
Posted 3 months ago. Jul 22, 2019 - 16:30 PDT
This incident affected: Warehouses (Redlands, CA).