Customer Care Phone Line Maintenance
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted May 04, 2020 - 14:18 PDT
Monitoring
We will be doing maintenance on our phone system on Monday, May 4th from 1:00-1:30 PM Pacific Time. Calls to our customer care phone line (1-888-SHIPWIRE) may be impacted during this 30-minute window, so please contact us at customercare@ingrammicroservices.com.
Posted May 01, 2020 - 07:13 PDT
This incident affected: Merchant portal (Dashboard).