Shipping delays out of Tilburg, NLD
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted 7 days ago. Jul 08, 2019 - 09:30 PDT
Investigating
In our Tilburg, NLD warehouse, an unusually high influx of orders has caused a system backup, resulting in operation slowdown and shipping delays. We expect all delayed orders to ship by tomorrow. We apologize for any inconvenience this may cause. For any questions or concerns, please contact customercare@ingrammicroservices.com
Posted 14 days ago. Jul 01, 2019 - 16:48 PDT
This incident affected: Warehouses (Tilburg, NLD).