Waalwijk, NLD- Delay in delivery of GLS shipments
Resolved
This incident has been resolved.
Posted Aug 09, 2022 - 13:44 PDT
Monitoring
Please be advised that the carrier GLS has notified Shipwire of potential delivery delays due to labor shortages. Transit time may be longer than normal. We will continue to keep you updated on this topic and thank you for your patience.
Posted Jul 27, 2022 - 13:34 PDT
This incident affected: Carriers (GLS (Netherlands)).