Delays due to U.S. Presidential Inauguration Security Restrictions
Resolved
This incident has been resolved.
Posted Jan 26, 2021 - 12:15 PST
Monitoring
Due to security restrictions in place for the upcoming U.S. Presidential Inauguration on Wednesday, Jan 20th, some areas within Washington D.C. and other locations within the U.S. may experience carrier service delays. We will be closely monitoring the situation and will continue to provide updates as more information becomes available.
Posted Jan 18, 2021 - 13:39 PST
This incident affected: Carriers (FedEx, UPS, USPS).