Finland postal strike disrupting deliveries
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted Dec 02, 2019 - 16:03 PST
Monitoring
The Finnish postal union is on strike. All postal deliveries throughout Finland will be delayed until the strike is over.
Posted Nov 26, 2019 - 11:42 PST
This incident affected: Carriers (Asendia, Australia Post, Canada Post, DHL eCommerce (Global Mail), Hong Kong Post, Netherlands Post, Royal Mail, USPS).