Australia Post & Toll - Orders on Hold
Resolved
Resolved.
Posted Sep 21, 2022 - 10:00 PDT
Identified
Please be advised that orders going out of the Eastern Creek, Australia facility on Toll and Australia Post International are currently on hold. We're looking to identify a fix for this issue and will advise on a timeline and recommendations shortly.
Posted Sep 19, 2022 - 11:33 PDT
This incident affected: Carriers (Australia Post, Toll) and Warehouses (Eastern Creek, AUS).