Toll Moves Customer-Facing IT Systems Offline due to Suspicious Activity
Resolved
This incident has been resolved.
Posted Jun 25, 2020 - 12:09 PDT
Monitoring
Toll has taken some of its IT systems offline after detecting unusual activity on its servers. Customer-facing systems, including Toll’s track-and-trace pages, as well as Toll’s contact centers are among the systems taken down.

Toll is still performing pickups from the Eastern Creek, AUS facility and delivering to your end-customers, although tracking shipments through Toll’s track-and-trace page will be unavailable until further notice.
Posted May 05, 2020 - 12:11 PDT
This incident affected: Warehouses (Eastern Creek, AUS) and Carriers (Toll).