Power Outage at Carol Stream, IL Warehouse
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 03, 2019 - 09:34 PDT
Identified
Due to a power outage at our Carol Stream, IL warehouse causing a delay in order flow from the Shipwire platform, orders shipping from this warehouse may be delayed. Our team expects power restoration by 6:00 pm CDT. For any questions or concerns, please contact customercare@ingrammicroservices.com.
Posted 3 months ago. Jul 01, 2019 - 15:34 PDT
This incident affected: Warehouses (Carol Stream, IL).