Delayed Shipments from Shenzhen, China Facility
Resolved
This incident has been resolved.
Posted May 07, 2020 - 07:54 PDT
Update
Our Shenzhen facility is slated to formally reopen on Monday, February 17 with 60% of our normal labor. Given the limited workforce, there will be delays in shipping. The workforce will continue to rise to normal numbers based on the coronoavirus situation in the local area. Thank you for your patience and understanding.
Posted Feb 13, 2020 - 10:48 PST
Update
As of February 10, we are continuing to monitor the Coronavirus situation with our operations team in Shenzhen, China. While our facility has passed local inspection, the final approval to re-open is awaiting final approval by local government. It is likely the facility will continue to be closed at least through February 11. We will continue to provide updates as they come.
Posted Feb 10, 2020 - 09:03 PST
Update
Due to the continued severity of the Coronavirus situation, the Chinese government has extended the Spring Festival holiday to February 10, 2020. Normal operations are expected to resume on February 11, 2020.
Posted Jan 30, 2020 - 08:08 PST
Monitoring
Shipments out of the Shenzhen, China facility are delayed due to Chinese New Year holidays and the on-going Coronavirus situation. As carriers and other operations are impacted, please expect delays for all inbound and outbound shipments through February 9, 2020. Safety of our associates is the top priority. We shall resume normal operations as soon as possible.
Posted Jan 28, 2020 - 15:21 PST
This incident affected: Warehouses (Shenzhen, CHN).