Royal Mail and Parcelforce Carrier Strikes
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 08:40 PDT
Monitoring
Please be advised that Royal Mail and Parcelforce carriers will be on strike on August 26th and August 31st. No deliveries will be made on those two days.
Posted Aug 23, 2022 - 09:13 PDT
This incident affected: Warehouses (Laughton-Lewes, GBR, Daventry, GBR) and Carriers (Parcel Force, Royal Mail).