USPS - 2022 Non Standard Surcharge
Resolved
This incident has been resolved.
Posted Jun 01, 2022 - 10:36 PDT
Identified
4/28/2022

Please be informed that there will be a USPS Non Standard Fee apply when package dimensions exceed USPS sortation specifications and require manual sorting. These fees are set to be placed on shipments using USPS Priority Mail, Priority Mail Express, and Parcel Select.

- Parcels that are longer than 22 inches but less than 30 inches will see a $4.00 surcharge.
- Parcels that exceed 30 inches in length will incur a $15.00 surcharge.
- Parcels that measure greater than 2 cubic (3456 cubic inches) feet will also see a $15.00 fee added.
A maximum of two non-standard fees may be assessed for a package.
Posted Apr 28, 2022 - 15:38 PDT
This incident affected: Carriers (USPS).