Email Communications Temporarily Down
Resolved
This incident has been resolved.
Posted Apr 24, 2019 - 13:55 PDT
Investigating
We are currently investigating an issue with customer communications via email. Customers temporarily may not receive business reports, sign up welcome emails, password resets, etc. We apologize for any inconvenience this may cause. For any questions or concerns, please contact customercare@ingrammicroservices.com
Posted Apr 23, 2019 - 13:38 PDT