Disable Shipments to Ukraine, Russia and Belarus Until Further Notice
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 09:35 PDT
Update
We are continuing to monitor for any further issues.
Posted Jun 01, 2022 - 10:36 PDT
Monitoring
March 4, 2022

We are disabling shipments to Ukraine, Russia and Belarus from all region due to carriers are currently suspending services there.
Will resume until further notice.
Posted Mar 22, 2022 - 14:02 PDT
This incident affected: Carriers (Australia Post, Canada Post, DHL eCommerce (Global Mail), DHL Express, DPD, FedEx, GLS (Netherlands), Hermes, Hong Kong Post, Netherlands Post, Purolator, Parcel Force, Royal Mail, StarTrack, Toll, UPS, USPS, ABM, SF Express).