Royal Mail and Parcelforce Carrier Strikes
Resolved
This incident has been resolved.
Posted Dec 27, 2022 - 05:01 PST
Update
The CWU has formally notified Royal Mail they plan to call on their members who collect, sort, and deliver parcels and letters to take national strike action on Wednesday 14 December, Thursday 15 December, Friday 23 December, and Saturday 24 December 2022. The strikes will likely cause delays in pick-ups and deliveries.
Posted Dec 14, 2022 - 01:35 PST
Monitoring
Please be advised that Royal Mail / Parcelforce have confirmed strike action dates for December 14-15, 2022. You can expect carrier pickup and delivery delays due to the strike.
Posted Dec 12, 2022 - 11:53 PST
Update
Please see the confirmed strike dates for Royal Mail and Parcel Force below.
Royal Mail - Strike action Nov 30, Dec 1, Dec 9, and Dec 11
Parcel Force - Strike action Nov 30, Dec 1, Dec 12, and Dec 11
Additionally, please note that DPD is facing delays at this time.
Posted Nov 30, 2022 - 12:42 PST
Update
Please read below about possible upcoming strikes for parcel carriers Royal Mail and Parcelforce which would impact our Daventry, GBR facility.

New national strike action dates announced by the CWU but have not been formally notified.
The CWU announced they will be notifying Royal Mail they plan to call on their members who collect, sort and deliver parcels and letters to take national strike action on Thursday 24 and Friday 25 November and for Wednesday 30 November and Thursday 1 December 2022.

We have not yet received formal notification of these new dates. The CWU has to provide 14 days’ notice before they can take any strike action.
Posted Nov 11, 2022 - 06:53 PST
Update
We have received more information about planned and potential Parcelforce strike dates, see below.

Parcelforce has confirmed the following strike dates (2022): October 13, 20, 25, and November 28 (Cyber Monday)

Parcelforce will also likely strike on the following dates (2022): November 3, 9, 15, 24, and December 1
Posted Oct 17, 2022 - 10:59 PDT
Identified
Please be advised that Royal Mail and Parcelforce are planning strike dates. Please expect delays in pickups and deliveries. There will be 24-hour strikes beginning at 4:00 AM on the following dates:

Thursday 13 October
Thursday 20 October
Tuesday 25 October
Monday 28 November

It's likely that smaller groups and teams will strike on various dates in November and December as well which may impact pickups and deliveries as well.

Processing, distribution, international, collections, and admin workers: November 3, 9, 15, 24, and December 1
Delivery workers: November 4, 10, 16, 25, and December 2
Network workers: November 2, 8, 14, 23, and 30
Posted Oct 04, 2022 - 12:26 PDT
This incident affected: Carriers (Parcel Force, Royal Mail).