Customer Support Email Down
Incident Report for Shipwire
Resolved
We have resolved the issue with our Customer Care email inbox (customercare@ingrammicroservices.com). It is once again working as normal. If you feel you have an open issue that requires assistance, please contact us again at that email address or give us a call at (650) 561-4800. We sincerely apologize for this inconvenience.
Posted Jul 11, 2019 - 15:39 PDT
Identified
Our customer care email inbox (customercare@ingrammicroservices.com) is currently experiencing technical difficulties and some messages are not being received at this time. We're urgently working on a fix for this. If you are currently engaging with support in an existing case, please keep the subject line of the email thread the same and send replies to sf-support-backup@shipwire.com rather than customercare@ingrammicroservices.com. You may also contact your account representative at their direct extension (found in their email signature).

For any other assistance needed in the meantime, please contact us at sf-support-backup@shipwire.com or (650) 561-4800.
Posted Jul 11, 2019 - 13:52 PDT
This incident affected: Merchant portal (Merchant Application, www.shipwire.com).