System Network Issues for Customer Care
Incident Report for Shipwire
Resolved
The network issue has been resolved. Thank you for your patience.
Posted 7 months ago. Jan 09, 2019 - 15:31 PST
Investigating
Our system network for customer care is currently experiencing issues and all tools are down. If you have customer care requests, please call the following hotline and our representatives can take note of issues and resolve once our systems are back up: 1-650-5614800 opt 1.
Please note: Emails will be delayed. We will provide updates as we work to resolve this issue. We apologize for any inconvenience this may cause and thank you for your patience.
Posted 7 months ago. Jan 09, 2019 - 09:20 PST