Earthquake disrupting delivery and retail operations in Puerto Rico
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 12:15 PDT
Update
The following Post Offices are closed until further notice. Delivery and retail operations will be temporarily relocated as indicated.

Ensenada Post Office, 6 Calle Segunda Sur, 00647 — Temporarily relocated to Guanica Post Office, 39 Calle 13 De Marzo, 00653. Hours are Monday through Friday, 8 a.m. to 4:15 p.m., and Saturday, 8 a.m. to noon.
Mayaguez Post Office, 60 Calle McKinley W., 00680 — Temporarily relocated to Marina Station (Mayaguez), 270 Calle De La Candelaria, 00682. Hours are Monday through Friday, 7 a.m. to 4:30 p.m., and Saturday, 8 a.m. to 3 p.m.
Yauco Post Office, 603 Yauco Plaza II, 00698 — Temporarily relocated to Centro Comunal Cesari, 17 Ave. 65 Infanteria, Yauco, 00698. Hours are Monday through Friday, 9 a.m. to 4:15 p.m., and Saturday, 9 a.m. to noon.
All stations in Arecibo, 00612, have resumed normal business hours.

Delivery and retail operations are being performed on a case by case basis depending on conditions.
Posted Feb 11, 2020 - 15:08 PST
Update
Due to the earthquakes, the following Post Offices are closed until further notice. Delivery and retail operations are temporarily relocated as indicated.

Coto Station, 22 Calle Centro Comercial, Arecibo, 00612 — Temporarily relocated to Arecibo Main Post Office, 10 Ave San Patricio, 00612. Hours are Monday through Friday, 9 a.m. to 6 p.m., and Saturday, 8 a.m. to 2 p.m.
Ensenada Post Office, 6 Calle Segunda Sur, 00647 — Temporarily relocated to Guanica Post Office, 39 Calle 13 De Marzo, 00653. Hours are Monday through Friday, 8 a.m. to 4:15 p.m., and Saturday, 8 a.m. to noon.
Mayaguez Post Office, 60 Calle McKinley W, 00680 — Temporarily relocated to Marina Station (Mayaguez), 270 Calle De La Candelaria, 00682. Hours are Monday through Friday, 7 a.m. to 4:30 p.m., and Saturday, 8 a.m. to 3 p.m.
Yauco Post Office, 603 Yauco Plaza II, 00698 — Temporarily relocated to Centro Comunal Cesari, 17 Ave 65 Infanteria, Yauco, 00698. Hours are Monday through Friday, 9 a.m. to 4:25 p.m, and Saturday, 9 a.m. to noon.

Delivery and retail operations are being performed on a case by case basis depending on conditions.
Posted Jan 13, 2020 - 12:03 PST
Monitoring
Due to a 6.4 magnitude earthquake that struck Puerto Rico, the following Post Offices are closed until further notice:

Canovanas Post Office, 00729 (Due to mall being closed)
Ensenada Post Office, 00647
Guanica Post Office, 00653
Mayaguez Post Office, 00681
Utuado Post Office, 00641
Yauco Post Office, 00698

The following Post Offices are expected to reopen Jan. 8:
Guayanilla, Post Office, 00656
Penuelas, Post Office, 00624
Ponce, Post Office, 00731
Plaza Carolina, Post Office, 00983
Plaza Las Americas, Post Office, 00918

Delivery and retail operations are being performed on a case by case basis depending on conditions.
Posted Jan 08, 2020 - 10:47 PST