Delays in Canadian Facilities
Resolved
This incident has been resolved.
Posted Feb 14, 2022 - 15:03 PST
Update
Due to severe winter weather conditions, public health protocols because of the Omicron Variant and increased volumes, the carriers are experiencing various delays across Canada. Please be advised of likely delays in the Ontario, Quebec and Newfoundland areas.
Posted Jan 19, 2022 - 13:52 PST
Update
January 18, 2022

As we continue to dig out of the massive Ontario snow event from yesterday, we are seeing that most major routes are cleared or in the process of getting cleared of snow. The carriers have confirmed that it’s business as usual today, all scheduled pickups and deliveries will occur today, however, delays are to be expected dependent on the road conditions.

ATS:

• Today’s pickups have resumed but may be delayed.


TFORCE – FINAL MILE:

• No closures at any TFORCE hubs, but everything is moving slow as things get back to normal.


PUROLATOR:
• Operations have resumed per normal as of today. Some delays in transit time due to inclement weather


CANADA POST:
• Pickups and deliveries will resume today, however it is possible that deliveries maybe delayed/canceled if roads are not safe to access.


UPS:
• No issues to report, Drivers are being dispatched and scheduled pickups and deliveries will happen.


FEDEX:
• Pickups and deliveries in scope for today, however there may be some transit delays due to weather and crew shortages.
Posted Jan 18, 2022 - 08:50 PST
Monitoring
As of this morning, the greater Toronto area is currently under a blizzard warning, with expected snowfall between 40 cm to 60 cm. Road conditions and attendance are impacting carrier pick-ups, delivery, and fulfillment operations in our Mississauga, Canada facility. Please expect fulfillment and carrier delays until further notice.
Posted Jan 17, 2022 - 12:56 PST
This incident affected: Warehouses (Mississauga, CAN).