Carrier Impacts due to Weather Events
Resolved
This incident has been resolved.
Posted Mar 09, 2021 - 10:29 PST
Update
Our Millington, TN facility has resumed normal operations and carrier pickups. Please be advised that delays in deliveries still may occur.
Posted Feb 24, 2021 - 08:49 PST
Update
Our Carrollton, TX facility has resumed normal operations and carrier pickups.

Due to severe weather events, there are still currently no carrier pickups from our Millington, TN facility. Please continue to anticipate delays in fulfillment and deliveries. We are monitoring this situation closely and will continue to provide updates as more information becomes available.
Posted Feb 22, 2021 - 10:47 PST
Update
Due to ongoing weather events, our Millington, TN and Carrollton, TX facilities are continued to be impacted. Please expect delays in fulfillment and deliveries until further notice.
Posted Feb 16, 2021 - 10:59 PST
Monitoring
Due to severe weather events, there are currently no carrier pickups from our Millington, TN and Carrollton, TX facilities. Please be advised that delays in deliveries will occur.

We are monitoring this situation closely and will continue to provide updates as more information becomes available.
Posted Feb 15, 2021 - 10:08 PST
This incident affected: Warehouses (Carrollton, TX, Millington, TN).