Transportation Disruptions in New South Wales and Victoria, Australia
Resolved
This incident has been resolved.
Posted Dec 20, 2022 - 13:07 PST
Investigating
Please be advised that flooding in areas in New South Wales and Victoria, Australia is causing transportation disruptions from our Eastern Creek, Australia facility.

Our priority is our employee and community safety and we will only attempt delivery into areas where allowed by authorities & emergency services on condition it is safe to do so. Articles in transit to locations that cannot be accessed will be held in transit in safe facilities until the local delivery centers are safe to access.
Posted Nov 16, 2022 - 05:55 PST
This incident affected: Warehouses (Eastern Creek, AUS).