Carriers unable to deliver shipments to areas hit by Hurricane Harvey
Resolved
Carrier pickup and delivery operations have resumed in Georgia, South Carolina, and Texas following the flooding caused by the recent hurricanes.
Posted Sep 19, 2017 - 17:16 PDT
Update
The remnants of Hurricane Harvey have caused hazardous conditions in Texas and Louisiana. Although contingency plans are in place and pickup/delivery operations have resumed, some service delays and disruptions can be anticipated for inbound and outbound shipments in both states. All carriers have committed to providing service to the best of their ability in areas that can be safely accessed.
Posted Sep 11, 2017 - 15:40 PDT
Monitoring
Damage due to Hurricane Harvey is preventing carriers from delivering to impacted areas of Texas and Louisiana. Service interruptions may last as long as several weeks.
Posted Aug 30, 2017 - 15:23 PDT
This incident affected: Carriers (Canada Post, DHL eCommerce (Global Mail), DHL Express, FedEx, Parcel Force, Royal Mail, UPS, USPS).